Power Pack 2 issues after install - 2015 Ford Mustang S550 Forum
 
LinkBack Thread Tools Search this Thread
post #1 of 2 Old 07-12-2018, 11:01 PM Thread Starter
Junior Member
 
Join Date: Jul 2018
Posts: 1
Power Pack 2 issues after install

Hello I am a new member but have owned mustangs for 26 years. Always a great pick for a muscle car. I currently have a 2015 Mustang GT performance package with 18000 miles, six speed manual, dark blue. The car is great. best muscle car I have ever owned.. But,,,, Last month after a cars and coffee meet I was looking at the same model car with the power pack 2 installed. The owner loved the performance gains. So I purchased the same power pack and installed it. I have been very impressed with the results. The only issue is if I hit the gas hard and launch from a stop it has a few flat spots in the acceleration. Almost like the computer is not fast enough to keep up with the air fuel mixture. I have also put on a borla ford performance exhaust including X pipe prior to installing the power pack 2. My question is what could be causing the flat spots, can I or the dealer fix this issue and has anyone else had this problem after installing the ford power pack 2.. Any help would be great

Last edited by Raybo; 07-12-2018 at 11:04 PM.
Raybo is offline  
post #2 of 2 Old 09-24-2018, 09:31 PM
Junior Member
 
Join Date: Sep 2018
Posts: 1
Do you have a oil separator installed. Ford Performance recommends it with PP2 helps some with pinging....Also our you using at least 91 octane.....Since you installed recently, you should have the latest updated tune....Make sure all your connections are tight and bolts.torqued right.......
rayban1 is offline  
Reply

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome